Being Prepared for Hurricane Ian Hitting the South and North Carolina Areas
Incident Report for Carolina Digital Phone Inc
Resolved
No power outages or internet outages affected any of the Carolina Digital Phone data centers and no services were affected.

In the event, you need us you can know we have staff that may be working remotely if needed and we have a full staff on board to help you with any changes you might need. We first ask that if possible send your support request to help@carolinadigitalphone.com and if needed urgently call (336) 346-6000 knowing we may be handling other customer issues there might be a delay.
Posted Oct 01, 2022 - 11:49 EDT
Investigating
Category 1 Hurricane Ian Forecast for Friday, September 30, 2022 - 2:00 pm EDT to hit the Charleston SC area.
Post-Tropical Cyclone Ian Forecast for Saturday, October 1, 2022 - 2:00 am EDT to hit the Charlotte NC area.

Please be advised our support staff are "all hands on deck" to assist in any business customer changes needed during the possible disruption of your business during the next few days. Our data centers are located in Greensboro NC, Research Triangle Park NC, and Dallas TX, in addition, we have data center servers in Ashburn VA, and also in Dublin OH. So we have full geo-redundancy for your voice and messaging services. In these locations, we have battery backups and generators to support us for up to two weeks without refueling.

That being said, we are dependent on the many thousands of internet connections throughout the area for our connection to you and likewise, you too are dependent on your local power company and internet services provider for us to provide you with telephone services. This is how we deliver your calls to you over the internet.

In the event, you need us you can know we have staff that may be working remotely if needed and we have a full staff on board to help you with any changes you might need. We first ask that if possible send your support request to help@carolinadigitalphone.com and if needed urgently call (336) 346-6000 knowing we may be handling other customer issues there might be a delay.

In the event of a major internet or power outage during this weather storm in one or more of our locations, you might drop a call but should be able to quickly pickup and place your call again, and receive inbound calls quickly after our geo-redundant design fails over. Please note that cellular data services for mobile users might also be affected if cellular towers are offline or lose connectivity.

We will continue to update this page in the event of any issues that might impact your business communications.

We encourage you to watch your local news or https://weather.com for weather issues and stay safe.
Posted Sep 29, 2022 - 21:15 EDT
This incident affected: Voice Services (Voice Services Platform - Greensboro, NC, Voice Services Platform - Research Triangle Park, NC, Voice Services Platform - Dallas, TX) and Applications Supporting Services (Voice Services Recording Server, Endpoints Device Registration Server).