Data Center Outage - Service Update: MCNC Data Center Maintenance

Incident Report for Carolina Digital Phone Inc

Resolved

Connectivity at the Raleigh, North Carolina, MCNC.ORG Data center has been restored.

Our geo-redundant voice services platform is designed to manage call traffic during events of this nature automatically. As expected, most services continued to operate normally. Impact was limited to devices configured with a single connection to the Raleigh data center, and geo-redundant connectivity across all voice services was not enabled.

During the transition, some browser-based applications may have relied on cached sessions and temporarily lost connectivity. This can be resolved by clearing the browser cache and reloading the application.

We appreciate your patience and understanding while service was fully restored.
Posted Dec 13, 2025 - 18:01 EST

Investigating

We are writing to provide an update regarding the network maintenance previously scheduled this morning at 5 am for our MCNC.org data center.

The planned upgrade work at MCNC has not yet been completed. To ensure continued service stability, we have temporarily routed all customer portals and mobile application traffic through our data centers in Greensboro, North Carolina, and Dallas, Texas. Services remain operational during this interim configuration.

This work is part of an ongoing effort to replace and upgrade switching infrastructure within the MCNC data center. The current maintenance window will focus on transitioning high-volume traffic flows to newly deployed core switches.

We appreciate your patience as this infrastructure work continues and will provide further updates as progress is made. If you have any questions or experience issues during this period, please contact Carolina Digital Phone support.
Posted Dec 13, 2025 - 12:15 EST
This incident affected: Voice Services (Voice Services Platform - Raleigh, NC), QoS Monitoring Services (QoS Voice Services Monitoring - Research Triangle Park, NC), and Web Portals (Voice Services Web Portal - Raleigh, NC).